APLCode tag always indents the first line

How to enrol; Forum policy; Entering APL characters; Discussions regarding Forum organization

APLCode tag always indents the first line

Postby norbertjurkiewicz84 on Wed Jun 21, 2017 1:49 pm

How do I stop this from happening when submitting examples with the "APLCode" tag?

aplcode.png
formatted aplcode
aplcode.png (3.65 KiB) Viewed 537 times



When I hit "Preview", the forums sets the first line of code after the opening [aplcode]tag.

Before & After (animated gif)
2017-06-21_09-46-17.gif
before and after



The result is the same when I click submit.

I did notice that clicking the "APLCode" button creates a tag with APLC being capitalized. However, after clicking Preview, the tag is now aplcode.
User avatar
norbertjurkiewicz84
 
Posts: 47
Joined: Mon Nov 01, 2010 7:26 pm

Re: APLCode tag always indents the first line

Postby AndyS|Dyalog on Thu Jun 22, 2017 8:34 am

Hi Norbert

I wish I could work out how to fix it .. Phil Last and I had a discussion about this back in 2011 (viewtopic.php?f=30&t=268&p=1058) but I found no way of getting this to work.

I'll take another look at some point ..
User avatar
AndyS|Dyalog
 
Posts: 165
Joined: Tue May 12, 2009 6:06 pm

Re: APLCode tag always indents the first line

Postby norbertjurkiewicz84 on Thu Jun 22, 2017 1:45 pm

Can you use a bit of JS to insert a line-break after the opening and before the closing APLCode tags?
User avatar
norbertjurkiewicz84
 
Posts: 47
Joined: Mon Nov 01, 2010 7:26 pm


Return to Using the Forum

Who is online

Users browsing this forum: No registered users and 1 guest