Forum Updates

How to enrol; Forum policy; Entering APL characters; Discussions regarding Forum organization

Forum Updates

Postby Jason|Dyalog on Fri Sep 23, 2011 3:40 pm

Over the last couple of days I have made a few tweaks to the forums. Some may not be noticed, others are tweaks, and there's a couple of extra features, too. Below is a list of all the changes that have been made:

* New Search engine installed - Search feature should now work.
* APL Buttons - There is now APL Buttons which will put the APL Character into your post, This is laid out the same way as the Dyalog Language bar within Dyalog APL. This also means that users that do not have access to an APL Keyboard are still able to put the characters into the forums (This will require APL385 Unicode font to be installed)
* TapaTalk availability. - The forums are now "Tapatalk" compatible, so if you have a mobile device (iPhone/iPad/Android) you will be able to install tapatalk from the appstore/marketplace and use the forums easily from these devices.

Any feedback on these features will be welcome.

Jason.
Jason|Dyalog
 
Posts: 22
Joined: Tue Sep 09, 2008 2:42 pm

Re: Forum Updates

Postby Tomas Gustafsson on Sat Sep 24, 2011 5:37 pm

* APL Buttons - There is now APL Buttons which will put the APL Character into your post

Very good, thx!

Where is the diamond? I'm blind, huh?
Tomas Gustafsson
 
Posts: 91
Joined: Mon Sep 19, 2011 6:43 pm

Re: Forum Updates

Postby Phil Last on Sat Sep 24, 2011 6:00 pm

No big deal but < (&lt;) and > (&gt;) are reversed and backslash \ seems not to work - perhaps something thinks it's an escape.

All three work on the keyboard with or without the IME so I shouldn't lose any sleep.
User avatar
Phil Last
 
Posts: 460
Joined: Thu Jun 18, 2009 6:29 pm

Re: Forum Updates

Postby Jason|Dyalog on Mon Sep 26, 2011 9:04 am

Tomas Gustafsson wrote:Where is the diamond? I'm blind, huh?


Nope, you're not blind, I had missed it! Diamond is now on the list, (just before ⍝)

Phil Last wrote:No big deal but < (&lt;) and > (&gt;) are reversed and backslash \ seems not to work - perhaps something thinks it's an escape.


Thanks Phil, These are now all fixed - if the number of characters becomes a problem, I may remove characters that are already on a standard keyboard.

Jason.
Jason|Dyalog
 
Posts: 22
Joined: Tue Sep 09, 2008 2:42 pm

Re: Forum Updates

Postby Dick Bowman on Mon Sep 26, 2011 12:54 pm

Are variant, lefttack and righttack also on the AWOL list?
Visit http://apl.dickbowman.com to read more from Dick Bowman
User avatar
Dick Bowman
 
Posts: 235
Joined: Thu Jun 18, 2009 4:55 pm

Re: Forum Updates

Postby Jason|Dyalog on Mon Sep 26, 2011 7:08 pm

Hi Dick.

These should now be here, it seems I was using an old version of the language bar, my apologies.

It also now has a slightly nicer look that will scale when you use your browsers "Zoom" function.

Jason.
Jason|Dyalog
 
Posts: 22
Joined: Tue Sep 09, 2008 2:42 pm

Re: Forum Updates

Postby Dick Bowman on Tue Sep 27, 2011 11:06 am

I see lefttack and righttack now, but no variant (Firefox 7.0, Opera 11.51, IE somethingrecent).

Plug-ugly character rendition in Firefox, but seems better with the other browsers (cup/cap not mirrors of each other, for instance). Maybe it's something about my font settings.

Another oddity is that yesterday (with Firefox) and with Opera/IE I see the characters in little boxes; but today Firefox is presenting just a row of characters.
Visit http://apl.dickbowman.com to read more from Dick Bowman
User avatar
Dick Bowman
 
Posts: 235
Joined: Thu Jun 18, 2009 4:55 pm

Re: Forum Updates

Postby Jason|Dyalog on Tue Sep 27, 2011 2:43 pm

Variant should be on the Language Bar. and as for the characters not in boxes, you may need to clear your browser cache and reload the page (if you cannot see Variant, this should also fix this issue)

As for the quality of font characters, there isn't a great deal I can do, this is down to the individual browsers rendering of characters.

Please send any further feedback on this directly to me or to the Dyalog Support team both by email.

Jason.
Jason|Dyalog
 
Posts: 22
Joined: Tue Sep 09, 2008 2:42 pm

Re: Forum Updates

Postby kai on Wed Sep 28, 2011 2:03 pm

User avatar
kai
 
Posts: 88
Joined: Thu Jun 18, 2009 5:10 pm
Location: Stevenage, UK

Re: Forum Updates

Postby Jason|Dyalog on Thu Sep 29, 2011 10:25 am

I have also now fixed the "Active Topics" - This now works as it should.

Jason
Jason|Dyalog
 
Posts: 22
Joined: Tue Sep 09, 2008 2:42 pm


Return to Using the Forum

Who is online

Users browsing this forum: No registered users and 1 guest